laravel 5.5 passport JWT 反序列化错误

passport 反序列化错误:

laravel 5.5 是 LTS 版本,配套的 passport 版本为 ~4.0 , 官方的最新的 release 版本为 4.0.3, 这个版本有一个 bug。

解决的办法为:

  1. 升级 laravel 5.5 到 laravel 5.6 版本
  2. 升级 passport 为 4.0.x-dev 版本,并在 app service provider 中增加 Passport::withoutCookieSerialization() 方法。